在rails中生成验证码时,报错了:This installation of RMagick was configured with ImageMagick 6.5.5 but ImageMagick 6.5.7-8 is in use. 我的解决办法是: 修改/usr/lib/ruby/1.8/RMagick.rb,在require “RMagick.so”之前加上:

RMAGICK_BYPASS_VERSION_TEST=true